Release Notes

What’s new in release 1.6

OpenTrack Version 1.6 contains many new functions that make it easier to work with the program and more powerful for users.

1. Preferences Export

Menu: Info -> Preferences

With Export all setting information (preferences, user settings) can be exported into a text file.

2. Selection of Switches

Menu: Edit -> Subselect Switches

Edit -> Subselect Switches selects the switches from the selected elements of the active worksheet and deselects all other elements.

3. Rename Documents

Menu: Document -> Rename

Document -> Rename can be used to rename files. In order to make certain that the connectors to associated documents are properly recognized all connecting infrastructure files need to be open when the document is renamed.
4. **New Toolbox Element**

**Menu:** Tools -> Toolbox/Palette

The new Pan-Element (toolbox - 2nd position) lets you quickly navigate around in large documents. To use the feature hold down the mouse button and move the mouse to the desired location on the document.

5. **Balise Icon**

**Menu:** Tools -> Inspector

The new balise symbol has a black arrow indicating the direction in which the beacon applies.

6. **Coasting Signal**

**Menu:** Tools -> Inspector

The *Coasting Signal* allows train to coast on a given section of track, the signal defines the allowable coasting behaviour, i.e. the train can accelerate to an upper coasting speed (*Upper Speed [km/h]*) , then the power can be turned off allowing the train to roll freely until it reaches the lower coasting speed (*Lower Speed [km/h]*) , at which point the power is switched on again.

Figure 1 illustrates an example with an upper speed set at 60 km/h and a lower speed set at 55 km/h.

![Figure 1: Coasting](image-url)
7. Dispatching at Exit-Signals

**Menu:** Tools -> Inspector

In previous versions of OpenTrack, the scheduling module tried to keep the exit signal closed for as long as possible (i.e. until the train is ready to leave) at every station stop. This was true even in cases when this caused the station entry signal to display a more restrictive proceed aspect because the exit signal was closed (and therefore it is not possible to reserve track beyond the station).

OpenTrack version 1.6 now includes a new attribute for exit signals *(Keep Closed for station stops)*, this allows users to define the operation of each exit signal individually. Selecting *Keep Closed for station stops* means that the exit signal will remain closed as usual for station stops. If this behaviour is not desired, then users can turn this feature off.

8. Signal Systems

**Menu:** Tools -> Inspector

Two new signaling systems are available:

- Universal (Metric): general Multi-Aspect-System using speeds in km/h
- Universal (US): general Multi-Aspect-System using speeds in mph

<table>
<thead>
<tr>
<th>Signal Aspect</th>
<th>Indication</th>
<th>OpenTrack Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear</td>
<td>Proceed</td>
<td>Track Speed</td>
</tr>
<tr>
<td>Proceed $v$</td>
<td>Proceed at Speed $v$</td>
<td>$P\ v$ (e.g. $P\ 50$)</td>
</tr>
<tr>
<td>Approach $v$</td>
<td>Proceed approaching next signal at restricted speed $v$. Trains exceeding restricted speed $v$ must begin reduction to restricted speed $v$ as soon as engine passes the Approach signal.</td>
<td>$A\ v$ (e.g. $A\ 50$)</td>
</tr>
<tr>
<td>Advance Approach $v$</td>
<td>Proceed approaching second signal at restricted speed $v$. Trains exceeding restricted speed $v$ must begin reduction to restricted speed $v$ as soon as engine passes the Approach signal.</td>
<td>$AA\ v$ (e.g. $AA\ 50$)</td>
</tr>
<tr>
<td>Stop</td>
<td>Stop</td>
<td>no add. settings needed (every main signal can show Stop)</td>
</tr>
</tbody>
</table>
9. Using the US NORAC system with OpenTrack

**Menu:** Tools -> Inspector

Signal Type: Main/Distant Sig. 3 Asp.
Aspects: Universal (US)

Limited speed: 50 mph
Medium speed: 30 mph
Slow speed: 15 mph

<table>
<thead>
<tr>
<th>Norac Signal Aspect</th>
<th>Indication</th>
<th>OpenTrack Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear</td>
<td>Proceed</td>
<td>Track Speed</td>
</tr>
<tr>
<td>Limited Clear</td>
<td>Proceed at Limited Speed until entire train clears all switches, then proceed.</td>
<td>P 50, define Slow Speed Zone</td>
</tr>
<tr>
<td>Medium Clear</td>
<td>Proceed at Medium Speed until entire train clears all switches, then proceed.</td>
<td>P 30, define Slow Speed Zone</td>
</tr>
<tr>
<td>Approach Limited</td>
<td>Proceed approaching the next signal at Limited Speed.</td>
<td>no add. settings needed (next signal shows P 50)</td>
</tr>
<tr>
<td>Approach Medium</td>
<td>Proceed approaching the next signal at Medium Speed.</td>
<td>no add. settings needed (next signal shows P 30)</td>
</tr>
<tr>
<td>Advance Approach</td>
<td>Proceed prepared to stop at the second signal. Trains exceeding Limited Speed must begin reduction to Limited Speed as soon as engine passes the Advance Approach signal.</td>
<td>AA 50</td>
</tr>
<tr>
<td>Medium Approach</td>
<td>Proceed prepared to stop at the next signal. Trains exceeding Medium Speed must begin reduction to Medium Speed as soon as the Medium Approach signal is clearly visible.</td>
<td>A 30 or P30</td>
</tr>
<tr>
<td>Approach</td>
<td>Proceed prepared to stop at the next signal. Trains exceeding Medium Speed must begin reduction to Medium Speed as soon as the engine passes the Approach signal.</td>
<td>A 30</td>
</tr>
<tr>
<td>Norac Signal Aspect</td>
<td>Indication</td>
<td>OpenTrack Setting</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Approach Slow</td>
<td>Proceed approaching the next signal at Slow Speed. Trains exceeding Medium Speed must begin reduction to Medium Speed as soon as the engine passes the Approach Slow signal.</td>
<td>A 30</td>
</tr>
<tr>
<td>Slow Clear</td>
<td>Proceed at Slow Speed until entire train clears all switches, then proceed.</td>
<td>P 15, define Slow Speed Zone</td>
</tr>
<tr>
<td>Slow Approach</td>
<td>Proceed prepared to stop at next signal. Slow Speed applies until entire train clears switches, then Medium Speed applies.</td>
<td>P 15, define Slow Speed Zone</td>
</tr>
<tr>
<td>Restricting</td>
<td>Proceed at Restricted Speed until the train has cleared all switches (if signal is CP signal) and the leading wheels have: 1. Passed a more favorable fixed signal. or 2. Entered non-signaled DCS territory</td>
<td>P v (v: restricted Speed), define Slow Speed Zone</td>
</tr>
<tr>
<td>Stop</td>
<td>Stop</td>
<td>no add. settings needed (every main signal can show Stop)</td>
</tr>
</tbody>
</table>

### 10. Station Database

**Menu:** Tools -> Stations

Two new attributes are available for stations:

Longitude: Geographic longitude (in degrees)
Latitude: Geographic latitude (in degrees)

Station databases, which contain the attributes of longitude and latitude, can be exported to Google Earth (kml format) using the command *(Functions -> Exchange Station Data -> Export Stations (Google Earth format))*

A new feature of the Station Control Panel is the checkbox: *Update changed ID in timetable*. When this is checked any changes made to a station ID is reflected in the timetable entries and connections databases.
11. Additional Formula for Curve Resistance

**Menu:** Tools -> Trains

In addition to the Roeckl formula for calculating curve resistance, OpenTrack provides a second formula for calculating curve resistance for trams:

\[ R_b = \frac{1+c}{r} \cdot 0.17 \cdot m \cdot g \]

- **R_b:** Curve resistance
- **c:** Distance of axles per bogie \[ c = \text{m} \]  
- **r:** Curve radius \[ r = \text{m} \]  
- **m:** Train weight (mass) \[ m = \text{kg} \]  
- **g:** Acceleration due to gravity \[ g = \text{m/s}^2 \]

12. New Train Attributes

**Menu:** Tools -> Trains

In order to realistically model trains that can be operated on both ETCS Level 2 and on conventional routes, OpenTrack enables users to define the braking characteristics (i.e. the Deceleration Function) of a train with a menu item, under which the properties are managed for both types of system (*Function Table: non-ETCS / ETCS*).

This information is presented in the Train Inspector's Deceleration Box.

In the case of a train that operates under ETCS control, the deceleration function table consists of four columns rather than three for trains operating only in non-ETCS controlled track. The third column of the table in both cases lists deceleration values for the area outside of the ETCS control. In the case of the trains operating under ETCS, a fourth column is displayed which lists deceleration values for the area managed under ETCS.

The ETCS values in the fourth column are the starting point for calculating the individual ETCS braking curves. These values are used along with the values for the braking application delay curve (Dec. Delay [s]) and the speed above which the delay is applied when operating under ETCS release speed (above [km/h]).
The Dec. Delay [s] and above [km/h] values are shown at the bottom of the Deceleration Box when ETCS is indicated on the pulldown menu in the bottom left corner of the Train Inspector's Deceleration Box.

Figure 3 shows a track section that contains one segment of ETCS Level 2 control. The beginning and end of the ETCS Level 2 control is shown by the cab signalling start/end signals (CAB Startsignal ETCS L2 or CAB Endsignal ETCS L2 in the signal inspector). The edges within the ETCS L2 controlled area have the property that signal information can be sent and received via radio (Loop / Radio ETCS in the Edge Inspector). These signals are marked as virtual signals (signal box is virtual in the Signal Inspector).

A train that starts at station A, which has the brake property: Function Table: non-ETCS / ETCS, will start operating as conventionally signalled train (calculating its braking curves according to the deceleration values in the third column of the table). Once the train reaches
the ETCS L2 zone, (the ETCS L2 zone is between the first block signal leaving station B and the last block signal before the station D entry signal), the train will calculate its braking curves based on the deceleration values presented in the fourth column of the table. When the train leaves the ETCS L2 zone, it goes back to using the third column values to calculate its braking curves.

![Graph showing speed vs. distance and acceleration vs. distance non-ETCS / ETCS Level 2](image)

Figure 4: Speed vs. distance and acceleration vs. distance non-ETCS / ETCS Level 2

Figure 4 shows the difference in train braking between the ETCS-section and the non-ETCS sections.

13. **Follow Train**

**Menu:** Tools -> Courses

OpenTrack now allows users to follow progress of a selected train as it progresses through the network documents. This is done by clicking in the appropriate checkbox (Follow Train) in the Analyzer (Tools -> Courses -> Analyze).

14. **Course Update**

**Menu:** Tools -> Courses

The schedule Update function, which allows users to construct a new train itinerary using the previously defined itineraries can now be accessed directly from the Course Panel (Tools -> Courses) and can be used for several user selected courses.
15. **New Timetable-Functions**

**Menu:** Tools -> Timetable

The Functions pull down menu (directly under the schedule entry table in the Timetable Management Window) contains several functions that can be applied to a set of selected schedule entries. The parameters of each function can be edited right from the menu in the text cell. Clicking on the Go button on the far right side causes the entries to be saved.

*Functions:*

- **Add Stops:** Enter a planned station stop
- **Remove Stops:** Remove a planned station stop
- **Set Mean Delay:** Enter average (mean) delay
- **Set Distr. Name:** Enter the name of the distribution function
- **Ins. Connection:** Enter a connection
- **Ins. Turnround to:** Enter a turnaround definition at the last station to a different train
- **Ins. Turnr. From:** Enter a turnaround definition at the first station to a different train

16. **Timetable Distribution Functions**

**Menu:** Tools -> Timetable

In previous versions of OpenTrack it was only possible to define an average (mean) delay (*Mean Delay*). OpenTrack version 1.6 now allows users to apply a predefined distribution function to schedule delays (using the menu item: **Tools -> Distributions**). Selecting the option *Show distribution name* causes a set of predefined distributions to be displayed. The user can then select the distribution that should be used for schedule delays.

17. **Connections**

**Menu:** Tools -> Timetable

New connections can be defined between stations; in other words, the stations column in the connection table can be edited directly. The default station of a connection is the station of the corresponding timetable entry.

18. **Distribution Tool**

**Menu:** Tools -> Distribution

OpenTrack uses distribution functions in several different modules including delay distribution (outlined in the sections above) and duration of incidents and disturbances in the simulation process. OpenTrack stores all the distributions in a central distributions database.

The OpenTrack distributions database stores user-defined distributions under a unique name
(this name is shown in OpenTrack functions that use the distribution function).

The distribution functions currently allowed by OpenTrack are in the form of *piecewise linear* distributions. These are formed by assigning a probability (Perc. [%]) that an event takes place within a user-defined time interval set using the (From [s]) and (To [s]) commands. The sum of the probabilities in the distribution should equal 100%, if this is not the case the probabilities column will be shown in red. OpenTrack provides commands for editing data, and deleting or adding intervals.

Figure 5 illustrates the Distributions Window showing an example distribution. The example distribution function indicates that there is a 10% possibility that the event will occur in the time between 0 and 10 seconds, a 80% possibility that it will occur in the time between 10 and 20 seconds, and a 10% possibility it will occur in the time between 20 and 60 seconds.

![Figure 5: Distribution Function Window](image)

### 19. Improved Incident Definition

**Menu:** Tools -> Incidents

OpenTrack version 1.6 includes several refinements designed to improve the modelling of incidents and disturbances. A new incident type (Edge Group - *Group of Edges*) has been introduced and additional options for incident characteristics have been provided.

Incidents can now include the following new attributes:

- **Probability:** probability of the incident occurring (in percent)
- **Begin Distr.:** Starting time for application of the incident distribution function (optional)
- **Duration Distr.:** Time duration of the incident distribution function (optional, if defined, then any specified end time for the incident will be ignored)
A further improvement is the functionality of OpenTrack's incident sets. The new version enables users to create incident sets which contain multiple incidents. The new function Update will remove all previously defined incidents from a set and builds a new set of incidents from the incidents selected by the user in the incident table (with the command Use).

20. **Train Graph / Train Diagram**

**Menu:** Tools -> Train Diagram

OpenTrack version 1.6 no longer supports the creation of overall simulation files (file type: .otsimnet), which were created after running a simulation.

A new feature of OpenTrack 1.6 is the ability for users to use a filter to select train categories (*Train Categories*). This enables users to create graphical timetables that do not include, for example, deadhead runs and/or shunting movements.

Another new feature is the ability to display the mileage on graphic timetables (users can select between *metric, UK* and *US* units).

21. **Simulation, Delay Information**

**Menu:** Tools -> Simulation

OpenTrack version 1.6 enables users to display a train's current delay in addition to its course number directly on the moving train in the *animation*. To use this function check the box *Delay* in the *animation control box*. The delay can be shown in seconds (*S: Sec.*), Minutes (*M: min*) or minutes and seconds (*M:SS*).

22. **Simulation: Occupation Output Definition**

**Menu:** Tools -> Simulation -> Output

OpenTrack version 1.6 now enables users to report occupancy statistics (occupancy rate, number of trains), for a user-defined time period (*Time Slot*) in addition to the peak hour values and average values for the entire simulation period available in previous versions.

23. **Simulation: Outputs**

**Menu:** Tools -> Simulation

The course statistics file (*OT_CourseStatistics.txt*) now contains the list of track sections used by each course.
24. **New Function: Delete all Routes**

**Menu:** Functions -> Delete all Routes

*Functions -> Delete all Routes* deletes all routes starting at the selected vertices.

25. **RailML-Timetable-Import**

**Menu:** Functions -> Exchange Timetable Data -> Import Timetable (RailML-Format)

OpenTrack version 1.6 provides two new options that can be used when importing schedule data (using *Merge*) from RailML:

- **Keep first Arrival Time:** First arrival time will not be overwritten
- **Keep last Departure Time:** Last departure time will not be overwritten.

26. **Infrastrukture Export to Netvisio**

**Menu:** Functions -> Exchange Infrastructure Data -> Export Infrastr. (Netvisio-Format)

The OpenTrack infrastructure data can now be exported to Netvisio (a visualization tool for railway networks). This requires that the coordinates of stations be included in the OpenTrack database.